Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.4

CVE-2016-3116: Dropbear SSH allows authenticated users to bypass command restrictions

CVE-2016-3116 · published 10 years ago
Summary

If you run Dropbear SSH on Debian versions older than 2016.72, a signed-in user can send specially crafted X11 forwarding data to run commands they are not supposed to. This could let them perform actions beyond their intended rights. Update Dropbear to the latest version or apply the available security patch to close the gap.

What to do
  • Update debian dropbear to version 2016.72-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian dropbear < 2016.72-1
Fix: upgrade to 2016.72-1
Debian:13 debian dropbear < 2016.72-1
Fix: upgrade to 2016.72-1
Debian:14 debian dropbear < 2016.72-1
Fix: upgrade to 2016.72-1
– dropbear_ssh_project dropbear_ssh <= 2015.71
cpe:2.3:a:dropbear_ssh_project:dropbear_ssh:*:*:*:*:*:*:*:*
Original advisory text
CRLF injection vulnerability in Dropbear SSH before 2016.72 allows remote authenticated users to bypass intended shell-command restrictions via crafted X11 forwarding data.
CRLF injection vulnerability in Dropbear SSH before 2016.72 allows remote authenticated users to bypass intended shell-command restrictions via crafted X11 forwarding data.
Severity
6.4 Medium
Exploitation
20% chance of attack within 30 days
Timeline
Published22 Mar 2016
Updated26 Oct 2026
First seen22 Sep 2026
Sources
CVE-2016-3116 · NVD
Track software like this
Free during beta