Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.5

CVE-2016-2550: Linux kernel before 4.5 lets users drain memory

CVE-2016-2550 · published 10 years ago
Summary

On systems running Linux kernels older than version 4.5, a local user can misuse a file handling mistake to consume large amounts of memory, potentially slowing or stopping the machine. This happens without needing special permissions and can affect any Debian-based installation using those kernels. Updating the kernel to version 4.5 or later (or applying the latest security patches) resolves the issue.

What to do
  • Update debian linux to version 4.4.4-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian linux < 4.4.4-1
Fix: upgrade to 4.4.4-1
Debian:13 debian linux < 4.4.4-1
Fix: upgrade to 4.4.4-1
Debian:14 debian linux < 4.4.4-1
Fix: upgrade to 4.4.4-1
– linux linux_kernel <= 4.4.8
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
Original advisory text
The Linux kernel before 4.5 allows local users to bypass file-descriptor limits and cause a denial of service (memory consumption) by leveraging incorrect tracking of descriptor ownership and sendi...
The Linux kernel before 4.5 allows local users to bypass file-descriptor limits and cause a denial of service (memory consumption) by leveraging incorrect tracking of descriptor ownership and sending each descriptor over a UNIX socket before closing it. NOTE: this vulnerability exists because of an incorrect fix for CVE-2013-4312.
Severity
5.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-399Resource Management Errors
Timeline
Published27 Apr 2016
Updated4 Nov 2026
First seen22 Sep 2026
Sources
CVE-2016-2550 · NVD
Track software like this
Free during beta