Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2016-10968: PeepSo plugin lets low‑privilege users gain admin rights
CVE-2016-10968 · published 7 years ago
Summary
The PeepSo Core plugin for WordPress, versions before 1.6.1, lets users who should have limited access change their own profile settings in a way that gives them higher privileges. This can allow an attacker to act as an administrator and modify site content or settings. Update the plugin to version 1.6.1 or later, or remove it if you cannot apply the update promptly.
What to do
- Update peepso peepso to version 1.6.1 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| peepso | peepso |
< 1.6.1 cpe:2.3:a:peepso:peepso:*:*:*:*:*:wordpress:*:* |
Original advisory text
The peepso-core plugin before 1.6.1 for WordPress has PeepSoProfilePreferencesAjax->save() privilege escalation.
The peepso-core plugin before 1.6.1 for WordPress has PeepSoProfilePreferencesAjax->save() privilege escalation.
References
- http://www.pritect.net/blog/peepso-1-6-0-logged-user-privilege-escalation Third Party Advisory
- https://wordpress.org/plugins/peepso-core/#developers Product Third Party Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-269Improper Privilege Management
Timeline
Published16 Sep 2019
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2016-10968 · NVD
Track software like this
Free during beta