Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2015-9286: Outgoing XSS in NodeBB 0.7.3 and earlier
CVE-2015-9286 · published 7 years ago
Summary
Using NodeBB, an attacker can inject malicious code into outgoing emails. This is a risk if you use NodeBB to send emails to users. To protect yourself, update NodeBB to version 0.7.3 or later.
What to do
- Update julianlam nodebb to version 0.8.2.
- Update nodebb nodebb to version 0.7.3 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| npm | julianlam | nodebb |
< 0.8.2 Fix: upgrade to 0.8.2
|
| – | nodebb | nodebb |
< 0.7.3 cpe:2.3:a:nodebb:nodebb:*:*:*:*:*:*:*:* |
Original advisory text
Controllers.outgoing in controllers/index.js in NodeBB before 0.7.3 has outgoing XSS.
Controllers.outgoing in controllers/index.js in NodeBB before 0.7.3 has outgoing XSS.
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-9286
- https://github.com/NodeBB/NodeBB/pull/3371
- https://github.com/NodeBB/NodeBB/compare/56b79a9...4de7529
- https://vulners.com/securityvulns/SECURITYVULNS:DOC:32625
- https://www.vulnerability-lab.com/get_content.php?id=1608
- https://github.com/advisories/GHSA-72fv-qgj6-2w2p
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published30 Apr 2019
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta