Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2015-8948: GNU libidn can leak memory to attackers

CVE-2015-8948 · published 10 years ago
Summary

The GNU libidn library may read past the end of its data when it receives an unexpected zero byte. This can let a remote attacker gather pieces of the server's memory, potentially exposing sensitive information. Updating to the latest version of the library resolves the issue.

What to do
  • Update alpine libidn to version 1.33-r0.
Affected software
Ecosystem VendorProductAffected versions
Alpine:v3.11 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.12 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.13 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.14 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.15 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.16 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.17 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.18 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.2 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.21 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.22 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.23 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.24 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.3 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.5 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.6 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.7 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.8 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.9 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.10 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.19 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.20 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
Alpine:v3.4 alpine libidn < 1.33-r0
Fix: upgrade to 1.33-r0
– opensuse leap 42.1
cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:*
– opensuse opensuse 13.2
cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
– canonical ubuntu_linux 12.04
14.04
16.04
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*
– gnu libidn <= 1.32
cpe:2.3:a:gnu:libidn:*:*:*:*:*:*:*:*
Original advisory text
idn in GNU libidn before 1.33 might allow remote attackers to obtain sensitive memory information by reading a zero byte as input, which triggers an out-of-bounds read.
idn in GNU libidn before 1.33 might allow remote attackers to obtain sensitive memory information by reading a zero byte as input, which triggers an out-of-bounds read.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.5 High
Exploitation
7% chance of attack within 30 days
Type
CWE-125Out-of-bounds Read
Timeline
Published7 Sep 2016
Updated3 Nov 2026
First seen27 Aug 2026
Sources
CVE-2015-8948 · NVD
Track software like this
Free during beta