Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2015-8778: glibc versions before 2.23 may crash or be exploited

CVE-2015-8778 · published 10 years ago
Summary

The standard Linux library called glibc (also known as libc6) in versions earlier than 2.23 has a mistake that can cause programs to stop working or, in rare cases, let an attacker run their own code. The problem is triggered by a special function that handles memory size calculations. Update the library to version 2.23 or later, or apply the vendor’s security patch, to eliminate the risk.

What to do
  • Update debian glibc to version 2.21-8.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian glibc < 2.21-8
Fix: upgrade to 2.21-8
Debian:13 debian glibc < 2.21-8
Fix: upgrade to 2.21-8
Debian:14 debian glibc < 2.21-8
Fix: upgrade to 2.21-8
– fedoraproject fedora 23
cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:*
– debian debian_linux 8.0
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
– canonical ubuntu_linux 12.04
14.04
15.10
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*
– gnu glibc <= 2.22
cpe:2.3:a:gnu:glibc:*:*:*:*:*:*:*:*
– suse linux_enterprise_debuginfo 11
cpe:2.3:a:suse:linux_enterprise_debuginfo:11:sp2:*:*:*:*:*:*
– opensuse opensuse 13.2
cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
– suse linux_enterprise_desktop 11
12
cpe:2.3:o:suse:linux_enterprise_desktop:11:sp3:*:*:*:*:*:*
– suse linux_enterprise_server 11
12
cpe:2.3:o:suse:linux_enterprise_server:11:sp2:*:*:lts:*:*:*
– suse linux_enterprise_software_development_kit 11
12
cpe:2.3:o:suse:linux_enterprise_software_development_kit:11:sp3:*:*:*:*:*:*
– suse suse_linux_enterprise_server 12
cpe:2.3:o:suse:suse_linux_enterprise_server:12:*:*:*:*:*:*:*
Original advisory text
Integer overflow in the GNU C Library (aka glibc or libc6) before 2.23 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via the...
Integer overflow in the GNU C Library (aka glibc or libc6) before 2.23 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via the size argument to the __hcreate_r function, which triggers out-of-bounds heap-memory access.
References
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
6% chance of attack within 30 days
Type
CWE-119Buffer Overflow
Timeline
Published19 Apr 2016
Updated31 Oct 2026
First seen9 Sep 2026
Sources
CVE-2015-8778 · NVD
Track software like this
Free during beta