Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2015-6511: pfSense before 2.2.3 lets attackers inject malicious script

CVE-2015-6511 · published 11 years ago
Summary

The web management page of pfSense versions earlier than 2.2.3 can be tricked into running attacker‑supplied code in a visitor’s browser. This could allow theft of login information or other actions performed as the logged‑in user. Update pfSense to version 2.2.3 or later to close the issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
netgate pfsense <= 2.2.2
cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*
Original advisory text
Cross-site scripting (XSS) vulnerability in pfSense before 2.2.3 allows remote attackers to inject arbitrary web script or HTML via the server[] parameter to services_ntpd.php.
Cross-site scripting (XSS) vulnerability in pfSense before 2.2.3 allows remote attackers to inject arbitrary web script or HTML via the server[] parameter to services_ntpd.php.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published18 Aug 2015
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2015-6511 · NVD
Track software like this
Free during beta