Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.6

CVE-2015-4625: PolicyKit <0.113 lets local users gain extra privileges

CVE-2015-4625 · published 11 years ago
Summary

Versions of PolicyKit prior to 0.113, as shipped with Fedora and openSUSE, contain a coding mistake that can be triggered by a local user opening many connections. This can let that user obtain higher system rights than intended. Upgrade PolicyKit to version 0.113 or newer to close the issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
fedoraproject fedora 21
22
cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:*
opensuse opensuse 13.1
13.2
cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*
polkit_project polkit <= 0.112
cpe:2.3:a:polkit_project:polkit:*:*:*:*:*:*:*:*
Original advisory text
Integer overflow in the authentication_agent_new_cookie function in PolicyKit (aka polkit) before 0.113 allows local users to gain privileges by creating a large number of connections, which trigge...
Integer overflow in the authentication_agent_new_cookie function in PolicyKit (aka polkit) before 0.113 allows local users to gain privileges by creating a large number of connections, which triggers the issuance of a duplicate cookie value.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.6 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-189Numeric Errors
Timeline
Published26 Oct 2015
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2015-4625 · NVD
Track software like this
Free during beta