Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.5

CVE-2015-4176: Linux kernel before 4.0.2 lets local users read any file

CVE-2015-4176 · published 10 years ago
Summary

The Linux kernel versions older than 4.0.2 have a mistake in how they handle mounted filesystems. This can let someone with local access use special privileges to view or delete files they shouldn't be able to. Upgrade the kernel to version 4.0.2 or later, or apply any provided patches, to close the gap.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
linux linux_kernel <= 4.0.1
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
Original advisory text
fs/namespace.c in the Linux kernel before 4.0.2 does not properly support mount connectivity, which allows local users to read arbitrary files by leveraging user-namespace root access for deletion ...
fs/namespace.c in the Linux kernel before 4.0.2 does not properly support mount connectivity, which allows local users to read arbitrary files by leveraging user-namespace root access for deletion of a file or directory.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-200Information Exposure
Timeline
Published2 May 2016
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2015-4176 · NVD
Track software like this
Free during beta