Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
10.0

CVE-2015-2788: DBD-Firebird before 1.19 can be crashed by remote attackers

CVE-2015-2788 · published 11 years ago
Summary

The DBD-Firebird Perl module versions earlier than 1.19, as packaged for Debian, contain a coding error that can overwrite memory when it processes certain data. An attacker who can send specially crafted information to a server using this module could cause the application to stop working or behave unpredictably. Upgrade the DBD-Firebird package to version 1.19 or later, or apply any patches provided by your Linux distribution, to eliminate the risk.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
debian debian_linux 7.0
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
debian dbd-firebird <= 1.18
cpe:2.3:a:debian:dbd-firebird:*:*:*:*:*:*:*:*
Original advisory text
Multiple stack-based buffer overflows in the ib_fill_isqlda function in dbdimp.c in DBD-Firebird before 1.19 allow remote attackers to have unspecified impact via unknown vectors that trigger an er...
Multiple stack-based buffer overflows in the ib_fill_isqlda function in dbdimp.c in DBD-Firebird before 1.19 allow remote attackers to have unspecified impact via unknown vectors that trigger an error condition, related to binding octets to columns.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
10.0 Critical
Exploitation
4% chance of attack within 30 days
Type
CWE-119Buffer Overflow
Timeline
Published14 Apr 2015
Updated25 Oct 2026
First seen29 Sep 2026
Sources
CVE-2015-2788 · NVD
Track software like this
Free during beta