Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2015-20108: Ruby-SAML XML Parsing Allows Malicious Code Execution

CVE-2015-20108 · published 3 years ago
Summary

A security issue in the Ruby-SAML library can allow attackers to inject malicious code and execute it, potentially leading to data theft or system compromise. This vulnerability affects Ruby applications using the ruby-saml gem before version 1.0.0. Update to the latest version to fix this issue.

What to do
  • Update saml toolkit ruby-saml to version 1.0.0.
  • Update onelogin ruby-saml to version 1.0.0 or later.
Affected software
Ecosystem VendorProductAffected versions
rubygems saml toolkit ruby-saml < 1.0.0
Fix: upgrade to 1.0.0
– onelogin ruby-saml < 1.0.0
cpe:2.3:a:onelogin:ruby-saml:*:*:*:*:*:*:*:*
Original advisory text
xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.
xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker full control
Severity
9.8 Critical
Exploitation
1% chance of attack within 30 days
Type
CWE-77Command Injection
Timeline
Published27 May 2023
Updated4 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta