Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2015-1788: OpenSSL older versions may hang during some secure connections

CVE-2015-1788 · published 11 years ago
Summary

Versions of the OpenSSL security library released before late 2012 can get stuck in an endless loop when they process a specially crafted request that uses a certain type of encryption. This can cause the server to stop responding, effectively a denial of service. Update OpenSSL to the latest release or apply the vendor’s security patch to resolve the issue.

What to do
  • Update debian openssl to version 1.0.2b-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian openssl < 1.0.2b-1
Fix: upgrade to 1.0.2b-1
Debian:13 debian openssl < 1.0.2b-1
Fix: upgrade to 1.0.2b-1
Debian:14 debian openssl < 1.0.2b-1
Fix: upgrade to 1.0.2b-1
– openssl openssl <= 0.9.8zf
1.0.0
1.0.0a
1.0.0b
1.0.0c
1.0.0d
1.0.0e
1.0.0f
1.0.0g
1.0.0h
1.0.0i
1.0.0j
24 more version ranges
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*
Original advisory text
The BN_GF2m_mod_inv function in crypto/bn/bn_gf2m.c in OpenSSL before 0.9.8s, 1.0.0 before 1.0.0e, 1.0.1 before 1.0.1n, and 1.0.2 before 1.0.2b does not properly handle ECParameters structures in w...
The BN_GF2m_mod_inv function in crypto/bn/bn_gf2m.c in OpenSSL before 0.9.8s, 1.0.0 before 1.0.0e, 1.0.1 before 1.0.1n, and 1.0.2 before 1.0.2b does not properly handle ECParameters structures in which the curve is over a malformed binary polynomial field, which allows remote attackers to cause a denial of service (infinite loop) via a session that uses an Elliptic Curve algorithm, as demonstrated by an attack against a server that supports client authentication.
References
Severity
4.3 Medium
Exploitation
20% chance of attack within 30 days
Type
CWE-399Resource Management Errors
Timeline
Published12 Jun 2015
Updated23 Oct 2026
First seen1 Sep 2026
Sources
CVE-2015-1788 · NVD
Track software like this
Free during beta