Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2015-1785: In nextgen-galery wordpress plugin before 2.0.77.3 there are two vulnerabilities which can allow an attacker to gain full access over the web application. The vulnerabilities lie in how the applica...

CVE-2015-1785 · published 4 years ago
Summary

In nextgen-galery wordpress plugin before 2.0.77.3 there are two vulnerabilities which can allow an attacker to gain full access over the web application. The vulnerabilities lie in how the application validates user uploaded files and lack of security measures preventing unwanted HTTP requests.

What to do
  • Update imagely nextgen_gallery to version 2.0.77.3 or later.
Affected software
VendorProductAffected versions
imagely nextgen_gallery < 2.0.77.3
cpe:2.3:a:imagely:nextgen_gallery:*:*:*:*:*:wordpress:*:*
Original advisory text
In nextgen-galery wordpress plugin before 2.0.77.3 there are two vulnerabilities which can allow an attacker to gain full access over the web application. The vulnerabilities lie in how the applica...
In nextgen-galery wordpress plugin before 2.0.77.3 there are two vulnerabilities which can allow an attacker to gain full access over the web application. The vulnerabilities lie in how the application validates user uploaded files and lack of security measures preventing unwanted HTTP requests.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-434Unrestricted File Upload
CWE-352Cross-Site Request Forgery (CSRF)
Timeline
Published7 Jul 2022
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2015-1785 · NVD
Track software like this
Free during beta