Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2014-9258: GLPI getDropdownValue.php lets logged‑in users run SQL

CVE-2014-9258 · published 11 years ago
Summary

The GLPI system’s ajax/getDropdownValue.php page can be tricked by a logged‑in user into running any database command through the condition input. This could let an attacker view, change, or delete data stored in the GLPI database. Apply the latest GLPI update (0.85.1 or newer) or patch the script to properly validate input.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
glpi-project glpi <= 0.85
cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*
Original advisory text
SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.
SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.5 Medium
Exploitation
3% chance of attack within 30 days
Type
CWE-89SQL Injection
Timeline
Published19 Dec 2014
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2014-9258 · NVD
Track software like this
Free during beta