Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.3
CVE-2014-9103: Kunena forum can run injected scripts
CVE-2014-9103 · published 11 years ago
Summary
The Kunena discussion component for Joomla can be tricked into inserting harmful web code when users upload files or images. This could let an attacker display unwanted content or steal information from visitors. Update Kunena to version 3.0.6 or later to stop the risk.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| kunena | kunena |
<= 3.0.5 cpe:2.3:a:kunena:kunena:*:*:*:*:*:joomla\!:*:* |
Original advisory text
Multiple cross-site scripting (XSS) vulnerabilities in the Kunena component before 3.0.6 for Joomla! allow remote attackers to inject arbitrary web script or HTML via the (1) index value of an arra...
Multiple cross-site scripting (XSS) vulnerabilities in the Kunena component before 3.0.6 for Joomla! allow remote attackers to inject arbitrary web script or HTML via the (1) index value of an array parameter or the filename parameter in the Content-Disposition header to the (2) file or (3) profile image upload functionality.
References
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Severity
4.3
Medium
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published26 Nov 2014
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2014-9103 · NVD
Track software like this
Free during beta