Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2014-6393: Old versions of Express.js may allow hackers to inject malicious code
CVE-2014-6393 · published 9 years ago
Summary
Old versions of the Express.js web framework for Node.js may allow hackers to inject malicious code into websites by sending specially crafted requests. This could allow them to take control of user sessions or steal sensitive information. To fix this, update to Express.js version 3.11 or later, or version 4.5 or later.
What to do
- Update jonchurch express to version 3.11.0.
- Update jonchurch express to version 4.5.0.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| npm | jonchurch | express |
< 3.11.0 >= 4.0.0, < 4.5.0 Fix: upgrade to 3.11.0
|
| – | openjsf | express |
<= 3.10.5 4.0.0 4.1.0 4.1.1 4.1.2 4.2.0 4.3.0 4.3.1 4.3.2 4.4.0 4.4.1 4.4.2 3 more version ranges
cpe:2.3:a:openjsf:express:*:*:*:*:*:*:*:* |
Original advisory text
The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to cond...
The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published9 Aug 2017
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta