Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2014-6051: LibVNCServer 0.9.9 and earlier crashes or executes malicious code
CVE-2014-6051 · published 12 years ago
Summary
LibVNCServer versions 0.9.9 and earlier may crash or allow malicious code to run if a remote VNC server sends a large screen size advertisement. This could lead to a disruption of service or unauthorized access. To protect your system, update to a fixed version of LibVNCServer.
What to do
- Update debian libvncserver to version 0.9.9+dfsg-6.1.
- Update debian veyon to version 4.1.4+repack1-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:11 | debian | libvncserver |
< 0.9.9+dfsg-6.1 Fix: upgrade to 0.9.9+dfsg-6.1
|
| Debian:12 | debian | libvncserver |
< 0.9.9+dfsg-6.1 Fix: upgrade to 0.9.9+dfsg-6.1
|
| Debian:13 | debian | libvncserver |
< 0.9.9+dfsg-6.1 Fix: upgrade to 0.9.9+dfsg-6.1
|
| Debian:14 | debian | libvncserver |
< 0.9.9+dfsg-6.1 Fix: upgrade to 0.9.9+dfsg-6.1
|
| Debian:11 | debian | veyon |
< 4.1.4+repack1-1 Fix: upgrade to 4.1.4+repack1-1
|
| Debian:12 | debian | veyon |
< 4.1.4+repack1-1 Fix: upgrade to 4.1.4+repack1-1
|
| Debian:13 | debian | veyon |
< 4.1.4+repack1-1 Fix: upgrade to 4.1.4+repack1-1
|
| Debian:14 | debian | veyon |
< 4.1.4+repack1-1 Fix: upgrade to 4.1.4+repack1-1
|
| – | redhat | enterprise_linux_server_aus |
6.5 cpe:2.3:o:redhat:enterprise_linux_server_aus:6.5:*:*:*:*:*:*:* |
| – | redhat | enterprise_linux_server_eus |
6.5.z cpe:2.3:o:redhat:enterprise_linux_server_eus:6.5.z:*:*:*:*:*:*:* |
| – | fedoraproject | fedora |
20 21 cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:* |
| – | libvncserver | libvncserver |
<= 0.9.9 cpe:2.3:a:libvncserver:libvncserver:*:*:*:*:*:*:*:* |
| – | debian | debian_linux |
7.0 cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* |
| – | oracle | solaris |
11.3 cpe:2.3:o:oracle:solaris:11.3:*:*:*:*:*:*:* |
Original advisory text
Integer overflow in the MallocFrameBuffer function in vncviewer.c in LibVNCServer 0.9.9 and earlier allows remote VNC servers to cause a denial of service (crash) and possibly execute arbitrary cod...
Integer overflow in the MallocFrameBuffer function in vncviewer.c in LibVNCServer 0.9.9 and earlier allows remote VNC servers to cause a denial of service (crash) and possibly execute arbitrary code via an advertisement for a large screen size, which triggers a heap-based buffer overflow.
References
- https://security-tracker.debian.org/tracker/CVE-2014-6051 Vendor Advisory
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/139654.ht... Third Party Advisory
- http://lists.fedoraproject.org/pipermail/package-announce/2014-September/139445.... Third Party Advisory
- http://lists.opensuse.org/opensuse-updates/2015-12/msg00022.html
- http://rhn.redhat.com/errata/RHSA-2015-0113.html Third Party Advisory
- http://seclists.org/oss-sec/2014/q3/639 Third Party Advisory
- http://secunia.com/advisories/61506 Permissions Required Third Party Advisory
- http://www.debian.org/security/2014/dsa-3081 Third Party Advisory
- http://www.ocert.org/advisories/ocert-2014-007.html Patch Third Party Advisory US Government Resource
- http://www.openwall.com/lists/oss-security/2014/09/25/11 Third Party Advisory
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html Third Party Advisory
- http://www.securityfocus.com/bid/70093
- https://github.com/newsoft/libvncserver/commit/045a044e8ae79db9244593fbce154cdf6... Patch Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
- https://security.gentoo.org/glsa/201507-07
- https://security.gentoo.org/glsa/201612-36
- https://usn.ubuntu.com/4587-1/
- https://www.kde.org/info/security/advisory-20140923-1.txt Third Party Advisory
Severity
7.5
High
Type
CWE-189Numeric Errors
Timeline
Published30 Sep 2014
Updated16 Oct 2026
First seen18 Aug 2026
Track software like this
Free during beta