Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.8

CVE-2014-5002: Lynx Gem for Ruby Exposes Password on Command Lines

CVE-2014-5002 · published 8 years ago
Summary

The Lynx Ruby gem before version 1.0.0 accidentally puts password configuration on the command line, which means a local user could potentially see and learn sensitive information, like passwords, by looking at running processes. This could be a concern for anyone using the Lynx gem in their Ruby application. To stay safe, update the Lynx gem to the latest version, 1.0.0 or later.

What to do
  • Update pan thomakos lynx to version 1.0.0.
  • Update lynx_project lynx to version 1.0.0 or later.
Affected software
Ecosystem VendorProductAffected versions
rubygems pan thomakos lynx <= 0.4.0
Fix: upgrade to 1.0.0
– lynx_project lynx < 1.0.0
cpe:2.3:a:lynx_project:lynx:*:*:*:*:*:ruby:*:*
Original advisory text
The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.
The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
7.8 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-200Information Exposure
CWE-255Credentials Management Errors
Timeline
Published10 Jan 2018
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2014-5002 · NVD
Track software like this
Free during beta