Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.3
CVE-2014-4692: pfSense before 2.1.4 may leak session cookie to scripts
CVE-2014-4692 · published 12 years ago
Summary
The web interface of pfSense versions earlier than 2.1.4 does not mark the session cookie as HTTPOnly when accessed over plain HTTP. This allows web pages running in a browser to read the cookie, potentially letting attackers steal it and hijack a logged‑in session. Upgrade to pfSense 2.1.4 or later, or ensure the interface is only accessed via HTTPS, to protect the cookie.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| netgate | pfsense |
<= 2.1.3 cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:* |
Original advisory text
pfSense before 2.1.4, when HTTP is used, does not include the HTTPOnly flag in a Set-Cookie header for the session cookie, which makes it easier for remote attackers to obtain potentially sensitive...
pfSense before 2.1.4, when HTTP is used, does not include the HTTPOnly flag in a Set-Cookie header for the session cookie, which makes it easier for remote attackers to obtain potentially sensitive information via script access to this cookie.
References
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Severity
4.3
Medium
Type
CWE-200Information Exposure
Timeline
Published2 Jul 2014
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2014-4692 · NVD
Track software like this
Free during beta