Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
2.9

CVE-2014-2568: Linux kernel upgrade may let attackers read private memory

CVE-2014-2568 · published 12 years ago
Summary

A flaw in older Linux kernel versions (up to 3.13.6) could let a remote attacker trick the system into revealing data stored in the core of the operating system. This happens because the code fails to correctly clean up after handling certain network packets. Updating the kernel to a newer version that includes the fix removes the risk.

What to do
  • Update debian linux to version 3.13.7-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian linux < 3.13.7-1
Fix: upgrade to 3.13.7-1
Debian:13 debian linux < 3.13.7-1
Fix: upgrade to 3.13.7-1
Debian:14 debian linux < 3.13.7-1
Fix: upgrade to 3.13.7-1
– linux linux_kernel >= 3.0, <= 3.13.6
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
– canonical ubuntu_linux 14.04
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
Original advisory text
Use-after-free vulnerability in the nfqnl_zcopy function in net/netfilter/nfnetlink_queue_core.c in the Linux kernel through 3.13.6 allows attackers to obtain sensitive information from kernel memo...
Use-after-free vulnerability in the nfqnl_zcopy function in net/netfilter/nfnetlink_queue_core.c in the Linux kernel through 3.13.6 allows attackers to obtain sensitive information from kernel memory by leveraging the absence of a certain orphaning operation. NOTE: the affected code was moved to the skb_zerocopy function in net/core/skbuff.c before the vulnerability was announced.
References
Severity
2.9 Low
Exploitation
1% chance of attack within 30 days
Type
CWE-416Use After Free
Timeline
Published24 Mar 2014
Updated31 Oct 2026
First seen1 Sep 2026
Sources
CVE-2014-2568 · NVD
Track software like this
Free during beta