Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2014-2236: Askbot before 0.7.49 lets attackers insert malicious scripts

CVE-2014-2236 · published 12 years ago
Summary

The Askbot discussion platform versions earlier than 0.7.49 can be tricked into running unwanted code when users view certain tags or search results. This could let an attacker display fake content, steal session data, or perform actions on behalf of users. Update Askbot to version 0.7.49 or later to close the issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
askbot askbot <= 0.7.48
0.7.40
0.7.41
0.7.42
0.7.43
0.7.44
0.7.45
0.7.46
0.7.47
cpe:2.3:a:askbot:askbot:*:*:*:*:*:*:*:*
Original advisory text
Multiple cross-site scripting (XSS) vulnerabilities in Askbot before 0.7.49 allow remote attackers to inject arbitrary web script or HTML via vectors related to the (1) tag or (2) user search forms.
Multiple cross-site scripting (XSS) vulnerabilities in Askbot before 0.7.49 allow remote attackers to inject arbitrary web script or HTML via vectors related to the (1) tag or (2) user search forms.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published5 Mar 2014
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2014-2236 · NVD
Track software like this
Free during beta