Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2014-100018: Unconfirmed WordPress plugin lets attackers add malicious code

CVE-2014-100018 · published 11 years ago
Summary

The Unconfirmed plugin for WordPress (versions before 1.2.5) can be tricked into running unwanted scripts or HTML when someone provides a specially crafted link. This could let a remote attacker display false information, steal data entered by users, or hijack user sessions. Update the plugin to version 1.2.5 or later, or remove it if it is not needed.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
unconfirmed_project unconfirmed <= 1.2.4
cpe:2.3:a:unconfirmed_project:unconfirmed:*:*:*:*:*:wordpress:*:*
Original advisory text
Cross-site scripting (XSS) vulnerability in the Unconfirmed plugin before 1.2.5 for WordPress allows remote attackers to inject arbitrary web script or HTML via the s parameter in the unconfirmed p...
Cross-site scripting (XSS) vulnerability in the Unconfirmed plugin before 1.2.5 for WordPress allows remote attackers to inject arbitrary web script or HTML via the s parameter in the unconfirmed page to wp-admin/network/users.php.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published13 Jan 2015
Updated4 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta