Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2013-7317: CS-Cart before 4.1.1 lets attackers add malicious code

CVE-2013-7317 · published 12 years ago
Summary

When CS-Cart versions prior to 4.1.1 process certain file parameters, a remote user can insert harmful web scripts or HTML. This could cause unwanted actions or data exposure for anyone who visits the affected pages. Update to version 4.1.1 or later, or apply the vendor's recommended patches, to stop this from happening.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
cs-cart cs-cart <= 4.0.3
1.3.0
1.3.2
1.3.3
1.3.4
2.0
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9
2.0.10
23 more version ranges
cpe:2.3:a:cs-cart:cs-cart:*:*:*:*:*:*:*:*
Original advisory text
Multiple cross-site scripting (XSS) vulnerabilities in CS-Cart before 4.1.1 allow remote attackers to inject arbitrary web script or HTML via the (1) settings_file or (2) data_file parameter to (a)...
Multiple cross-site scripting (XSS) vulnerabilities in CS-Cart before 4.1.1 allow remote attackers to inject arbitrary web script or HTML via the (1) settings_file or (2) data_file parameter to (a) ampie.swf, (b) amline.swf, or (c) amcolumn.swf.
References
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published24 Jan 2014
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2013-7317 · NVD
Track software like this
Free during beta