Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2013-3484: dotCMS before 2.3.2 lets attackers insert malicious scripts

CVE-2013-3484 · published 12 years ago
Summary

Versions of dotCMS older than 2.3.2 can be tricked into running unwanted code when a user’s login or password‑reset fields are manipulated. This could let an attacker display fake pages, steal data, or hijack user sessions. Update dotCMS to version 2.3.2 or later, or apply the vendor’s patches, to stop the issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
dotcms dotcms <= 2.3.1
1.9.5.1
2.0
2.0.1
2.1
2.1.1
2.2
2.2.1
2.3
cpe:2.3:a:dotcms:dotcms:*:*:*:*:*:*:*:*
Original advisory text
Multiple cross-site scripting (XSS) vulnerabilities in dotCMS before 2.3.2 allow remote attackers to inject arbitrary web script or HTML via the (1) _loginUserName parameter to application/login/lo...
Multiple cross-site scripting (XSS) vulnerabilities in dotCMS before 2.3.2 allow remote attackers to inject arbitrary web script or HTML via the (1) _loginUserName parameter to application/login/login.html, (2) my_account_login parameter to c/portal_public/login, or (3) email parameter to forgotPassword.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published2 Apr 2014
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2013-3484 · NVD
Track software like this
Free during beta