Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.3
CVE-2013-0771: Firefox, Thunderbird, SeaMonkey may run malicious code
CVE-2013-0771 · published 13 years ago
Summary
Older versions of Firefox (before 18), Thunderbird (before 17.0.2), and SeaMonkey (before 2.15) can be tricked by a specially crafted document to run unwanted programs. The problem is caused by a flaw in how text is processed. Upgrade these applications to the latest releases or apply the vendor's security patches as soon as possible.
What to do
- Update mozilla seamonkey to version 2.15 or later.
- Update mozilla thunderbird to version 17.0.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| mozilla | firefox |
< 18.0 >= 10.0, < 10.0.12 >= 17.0, < 17.0.2 cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* |
| mozilla | seamonkey |
< 2.15 cpe:2.3:a:mozilla:seamonkey:*:*:*:*:*:*:*:* |
| mozilla | thunderbird |
< 17.0.2 cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:* |
| mozilla | thunderbird_esr |
>= 10.0, < 10.0.12 >= 17.0, < 17.0.2 cpe:2.3:a:mozilla:thunderbird_esr:*:*:*:*:*:*:*:* |
| opensuse | opensuse |
11.4 12.1 12.2 cpe:2.3:o:opensuse:opensuse:11.4:*:*:*:*:*:*:* |
| suse | linux_enterprise_desktop |
10 11 cpe:2.3:o:suse:linux_enterprise_desktop:10:sp4:*:*:*:*:*:* |
| suse | linux_enterprise_server |
10 11 cpe:2.3:o:suse:linux_enterprise_server:10:sp4:*:*:*:*:*:* |
| suse | linux_enterprise_software_development_kit |
10 11 cpe:2.3:o:suse:linux_enterprise_software_development_kit:10:sp4:*:*:*:*:*:* |
| canonical | ubuntu_linux |
10.04 11.10 12.04 12.10 cpe:2.3:o:canonical:ubuntu_linux:10.04:*:*:*:-:*:*:* |
Original advisory text
Heap-based buffer overflow in the gfxTextRun::ShrinkToLigatureBoundaries function in Mozilla Firefox before 18.0, Firefox ESR 17.x before 17.0.1, Thunderbird before 17.0.2, Thunderbird ESR 17.x bef...
Heap-based buffer overflow in the gfxTextRun::ShrinkToLigatureBoundaries function in Mozilla Firefox before 18.0, Firefox ESR 17.x before 17.0.1, Thunderbird before 17.0.2, Thunderbird ESR 17.x before 17.0.1, and SeaMonkey before 2.15 allows remote attackers to execute arbitrary code via a crafted document.
References
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00006.html Mailing List Third Party Advisory
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00007.html Mailing List Third Party Advisory
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00010.html Mailing List Third Party Advisory
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00017.html Mailing List Third Party Advisory
- http://www.mozilla.org/security/announce/2013/mfsa2013-02.html Vendor Advisory
- http://www.ubuntu.com/usn/USN-1681-1 Third Party Advisory
- http://www.ubuntu.com/usn/USN-1681-2 Third Party Advisory
- http://www.ubuntu.com/usn/USN-1681-4 Third Party Advisory
- https://bugzilla.mozilla.org/show_bug.cgi?id=785555 Issue Tracking Patch Vendor Advisory
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3... Third Party Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Severity
9.3
Critical
Type
CWE-787Out-of-bounds Write
Timeline
Published13 Jan 2013
Updated22 Oct 2026
First seen29 Sep 2026
Sources
CVE-2013-0771 · NVD
Track software like this
Free during beta