Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.2

CVE-2013-0294: pyrad before 2.1 may expose passwords to attackers

CVE-2013-0294 · published 6 years ago
Summary

The pyrad library versions earlier than 2.1 create authentication data using numbers that are not random enough. This makes it easier for a remote attacker to guess passwords by trying many possibilities. Upgrade pyrad to version 2.1 or later to use stronger random numbers and protect sensitive information.

What to do
  • Update christian giese pyrad to version 2.1.
  • Update debian pyrad to version 2.0-2.
  • Update pyrad_project pyrad to version 2.1 or later.
Affected software
Ecosystem VendorProductAffected versions
pip christian giese pyrad < 2.1
Fix: upgrade to 2.1
Debian:12 debian pyrad < 2.0-2
Fix: upgrade to 2.0-2
Debian:13 debian pyrad < 2.0-2
Fix: upgrade to 2.0-2
Debian:14 debian pyrad < 2.0-2
Fix: upgrade to 2.0-2
– pyrad_project pyrad < 2.1
cpe:2.3:a:pyrad_project:pyrad:*:*:*:*:*:*:*:*
– fedoraproject fedora 18
19
20
cpe:2.3:o:fedoraproject:fedora:18:*:*:*:*:*:*:*
Original advisory text
packet.py in pyrad before 2.1 uses weak random numbers to generate RADIUS authenticators and hash passwords, which makes it easier for remote attackers to obtain sensitive information via a brute f...
packet.py in pyrad before 2.1 uses weak random numbers to generate RADIUS authenticators and hash passwords, which makes it easier for remote attackers to obtain sensitive information via a brute force attack.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
8.2 High
Exploitation
3% chance of attack within 30 days
Type
CWE-330Use of Insufficiently Random Values
Timeline
Published28 Jan 2020
Updated31 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta