Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
1.9

CVE-2012-6548: Linux kernel before 3.6 may leak memory to local users

CVE-2012-6548 · published 13 years ago
Summary

The Linux operating system versions older than 3.6 contain a coding mistake that can expose parts of the system’s memory to anyone with access to the computer. An attacker could run a specially crafted program to read data that should remain hidden. Upgrade to a newer kernel version or apply the available security patches to stop this from happening.

What to do
  • Update debian linux to version 3.2.41-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian linux < 3.2.41-1
Fix: upgrade to 3.2.41-1
Debian:13 debian linux < 3.2.41-1
Fix: upgrade to 3.2.41-1
Debian:14 debian linux < 3.2.41-1
Fix: upgrade to 3.2.41-1
– linux linux_kernel <= 3.5.7
3.0
3.0.1
3.0.2
3.0.3
3.0.4
3.0.5
3.0.6
3.0.7
3.0.8
3.0.9
3.0.10
148 more version ranges
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
– redhat enterprise_linux 6.0
cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:*
Original advisory text
The udf_encode_fh function in fs/udf/namei.c in the Linux kernel before 3.6 does not initialize a certain structure member, which allows local users to obtain sensitive information from kernel heap...
The udf_encode_fh function in fs/udf/namei.c in the Linux kernel before 3.6 does not initialize a certain structure member, which allows local users to obtain sensitive information from kernel heap memory via a crafted application.
Severity
1.9 Low
Exploitation
<1% chance of attack within 30 days
Type
CWE-200Information Exposure
Timeline
Published15 Mar 2013
Updated4 Nov 2026
First seen5 Sep 2026
Sources
CVE-2012-6548 · NVD
Track software like this
Free during beta