Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.1
CVE-2012-4545: ELinks before 0.12pre6 can let remote servers act as the user
CVE-2012-4545 · published 13 years ago
Summary
The web browser ELinks versions prior to 0.12pre6 can forward your login credentials to a remote site when using certain authentication methods. This could allow the remote site to impersonate you on other services. Update to the latest version of ELinks or disable Negotiate/GSS authentication to stop the credential forwarding.
What to do
- Update debian elinks to version 0.12~pre5-9.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | elinks |
< 0.12~pre5-9 Fix: upgrade to 0.12~pre5-9
|
| Debian:13 | debian | elinks |
< 0.12~pre5-9 Fix: upgrade to 0.12~pre5-9
|
| Debian:14 | debian | elinks |
< 0.12~pre5-9 Fix: upgrade to 0.12~pre5-9
|
| – | elinks | elinks |
0.12 cpe:2.3:a:elinks:elinks:0.12:pre1:*:*:*:*:*:* |
Original advisory text
The http_negotiate_create_context function in protocol/http/http_negotiate.c in ELinks 0.12 before 0.12pre6, when using HTTP Negotiate or GSS-Negotiate authentication, delegates user credentials th...
The http_negotiate_create_context function in protocol/http/http_negotiate.c in ELinks 0.12 before 0.12pre6, when using HTTP Negotiate or GSS-Negotiate authentication, delegates user credentials through GSSAPI, which allows remote servers to authenticate as the client via the delegated credentials.
References
- https://security-tracker.debian.org/tracker/CVE-2012-4545 Vendor Advisory
- http://bugzilla.elinks.cz/show_bug.cgi?id=1124
- http://repo.or.cz/w/elinks.git/blobdiff/89056e21fc7ab8e1c2d4e06ec9d0c6d01e70669a...
- http://rhn.redhat.com/errata/RHSA-2013-0250.html
- http://secunia.com/advisories/51569 Vendor Advisory
- http://www.debian.org/security/2012/dsa-2592
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:075
- http://www.securityfocus.com/bid/57065
- https://exchange.xforce.ibmcloud.com/vulnerabilities/80882
Severity
5.1
Medium
Type
CWE-287Improper Authentication
Timeline
Published3 Jan 2013
Updated4 Nov 2026
First seen5 Sep 2026
Track software like this
Free during beta