Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2012-4438: Jenkins: Unauthorized Data Insertion and Code Execution via Remote Access
CVE-2012-4438 · published 6 years ago
Summary
A security issue in Jenkins allows attackers with access to the Jenkins master server to insert data and run malicious code, potentially compromising the security and integrity of the system. This affects versions of Jenkins prior to 1.482 and 1.466.2 LTS. To ensure security, update Jenkins to the latest version or patch level.
What to do
- Update jenkins-ci org.jenkins-ci.main:jenkins-core to version 1.466.2.
- Update jenkins-ci org.jenkins-ci.main:jenkins-core to version 1.482.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| maven | jenkins-ci | org.jenkins-ci.main:jenkins-core |
< 1.466.2 >= 1.467, < 1.482 Fix: upgrade to 1.466.2
|
| – | jenkins | jenkins |
< 1.466.2 < 1.482 cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* |
Original advisory text
Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers with read access and HTTP access to Jenkins master to insert data and execute arbitrary code.
Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers with read access and HTTP access to Jenkins master to insert data and execute arbitrary code.
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-4438
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-4438
- https://security-tracker.debian.org/tracker/CVE-2012-4438
- https://www.cloudbees.com/jenkins-security-advisory-2012-09-17
- http://www.openwall.com/lists/oss-security/2012/09/21/2
- https://github.com/advisories/GHSA-wr6p-j63r-xqhv
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-20Improper Input Validation
Timeline
Published18 Nov 2019
Updated29 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta