Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2012-4343: Gallery 3 may let attackers run code

CVE-2012-4343 · published 14 years ago
Summary

Versions of Gallery 3 older than 3.0.4 can be tricked into running malicious code on the server. This could let an attacker take control of the system or steal data. Update to version 3.0.4 or later as soon as possible.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
menalto gallery <= 3.0.3
3.0
3.0.1
3.0.2
cpe:2.3:a:menalto:gallery:*:*:*:*:*:*:*:*
Original advisory text
Multiple unspecified vulnerabilities in Gallery 3 before 3.0.4 allow attackers to execute arbitrary PHP code via unknown vectors.
Multiple unspecified vulnerabilities in Gallery 3 before 3.0.4 allow attackers to execute arbitrary PHP code via unknown vectors.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.5 High
Exploitation
1% chance of attack within 30 days
Timeline
Published15 Aug 2012
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2012-4343 · NVD
Track software like this
Free during beta