Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
10.0

CVE-2012-2785: FFmpeg before 0.11 may mishandle crafted media files

CVE-2012-2785 · published 14 years ago
Summary

Versions of FFmpeg older than 0.11 contain coding mistakes in the component that decodes lossless WM audio. A specially crafted audio file could cause the program to behave unexpectedly, potentially leading to a crash or other unintended actions. Update FFmpeg to version 0.11 or later to remove the risk.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
ffmpeg ffmpeg <= 0.10.4
0.3
0.3.1
0.3.2
0.3.3
0.3.4
0.4.0
0.4.2
0.4.3
0.4.4
0.4.5
0.4.6
41 more version ranges
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:*
Original advisory text
Multiple unspecified vulnerabilities in libavcodec/wmalosslessdec.c in FFmpeg before 0.11 have unknown impact and attack vectors, related to (1) "some subframes only encode some channels" or (2) a ...
Multiple unspecified vulnerabilities in libavcodec/wmalosslessdec.c in FFmpeg before 0.11 have unknown impact and attack vectors, related to (1) "some subframes only encode some channels" or (2) a large order value.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
10.0 Critical
Exploitation
3% chance of attack within 30 days
Timeline
Published10 Sep 2012
Updated30 Oct 2026
First seen29 Sep 2026
Sources
CVE-2012-2785 · NVD
Track software like this
Free during beta