Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.3
CVE-2012-2641: Zenphoto up to 1.4.2 lets attackers add malicious scripts
CVE-2012-2641 · published 14 years ago
Summary
If your website runs Zenphoto version 1.4.2 or earlier, an attacker could place their own code into pages that visitors see. This could be used to steal information or trick users into clicking harmful links. Update Zenphoto to version 1.4.3 or later, or apply the vendor's patch, to stop the risk.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| zenphoto | zenphoto |
<= 1.4.2 0.9 1.0 1.0.1 1.0.4 1.0.5 1.0.6 1.1 1.1.1 1.1.2 1.1.3 1.1.7 3 more version ranges
cpe:2.3:a:zenphoto:zenphoto:*:*:*:*:*:*:*:* |
Original advisory text
Cross-site scripting (XSS) vulnerability in Zenphoto before 1.4.3 allows remote attackers to inject arbitrary web script or HTML by triggering improper interaction with an unspecified library.
Cross-site scripting (XSS) vulnerability in Zenphoto before 1.4.3 allows remote attackers to inject arbitrary web script or HTML by triggering improper interaction with an unspecified library.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Severity
4.3
Medium
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published5 Jul 2012
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2012-2641 · NVD
Track software like this
Free during beta