Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.8

CVE-2012-2142: Poppler before 0.21.4 can run attacker commands

CVE-2012-2142 · published 6 years ago
Summary

The Poppler software that processes PDF files can be tricked by a specially crafted PDF to run commands on your computer. This could let someone take control of the system or steal data. Upgrade Poppler to version 0.21.4 or later and apply any security updates to stop the risk.

What to do
  • Update debian poppler to version 0.18.4-7.
  • Update freedesktop poppler to version 0.21.4 or later.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian poppler < 0.18.4-7
Fix: upgrade to 0.18.4-7
Debian:13 debian poppler < 0.18.4-7
Fix: upgrade to 0.18.4-7
Debian:14 debian poppler < 0.18.4-7
Fix: upgrade to 0.18.4-7
– freedesktop poppler < 0.21.4
cpe:2.3:a:freedesktop:poppler:*:*:*:*:*:*:*:*
– xpdfreader xpdf 3.02
cpe:2.3:a:xpdfreader:xpdf:3.02:*:*:*:*:*:*:*
– redhat enterprise_linux 5.0
6.0
cpe:2.3:o:redhat:enterprise_linux:5.0:*:*:*:*:*:*:*
– opensuse opensuse 12.2
cpe:2.3:o:opensuse:opensuse:12.2:*:*:*:*:*:*:*
Original advisory text
The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.
The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.
Severity
7.8 High
Exploitation
3% chance of attack within 30 days
Timeline
Published9 Jan 2020
Updated31 Oct 2026
First seen3 Sep 2026
Sources
CVE-2012-2142 · NVD
Track software like this
Free during beta