Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2012-1595: Wireshark older versions can crash when opening crafted capture files

CVE-2012-1595 · published 14 years ago
Summary

Wireshark versions 1.4 up to 1.4.11 and 1.6 up to 1.6.5 may stop working if they open a specially crafted network capture file. An attacker could send such a file to make the program close unexpectedly, interrupting monitoring activities. Update Wireshark to version 1.4.12, 1.6.6, or later, or avoid opening capture files from untrusted sources.

What to do
  • Update debian wireshark to version 1.6.6-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian wireshark < 1.6.6-1
Fix: upgrade to 1.6.6-1
Debian:13 debian wireshark < 1.6.6-1
Fix: upgrade to 1.6.6-1
Debian:14 debian wireshark < 1.6.6-1
Fix: upgrade to 1.6.6-1
– wireshark wireshark 1.4.0
1.4.1
1.4.2
1.4.3
1.4.4
1.4.5
1.4.6
1.4.7
1.4.8
1.4.9
1.4.10
1.4.11
6 more version ranges
cpe:2.3:a:wireshark:wireshark:1.4.0:*:*:*:*:*:*:*
Original advisory text
The pcap_process_pseudo_header function in wiretap/pcap-common.c in Wireshark 1.4.x before 1.4.12 and 1.6.x before 1.6.6 allows remote attackers to cause a denial of service (application crash) via...
The pcap_process_pseudo_header function in wiretap/pcap-common.c in Wireshark 1.4.x before 1.4.12 and 1.6.x before 1.6.6 allows remote attackers to cause a denial of service (application crash) via a WTAP_ENCAP_ERF file containing an Extension or Multi-Channel header with an invalid pseudoheader size, related to the pcap and pcap-ng file parsers.
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-399Resource Management Errors
Timeline
Published11 Apr 2012
Updated3 Nov 2026
First seen3 Sep 2026
Sources
CVE-2012-1595 · NVD
Track software like this
Free during beta