Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2012-0834: phpLDAPadmin query page can run attacker script

CVE-2012-0834 · published 14 years ago
Summary

Versions of phpLDAPadmin up to 1.2.2 let a remote user place their own web script or HTML into the query page. When a staff member views the page, the malicious code runs in their browser, potentially stealing credentials or performing actions as that user. Upgrade phpLDAPadmin to the latest release or apply the vendor's patch, and ensure input filtering is in place.

What to do
  • Update debian phpldapadmin to version 1.2.2-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian phpldapadmin < 1.2.2-1
Fix: upgrade to 1.2.2-1
Debian:13 debian phpldapadmin < 1.2.2-1
Fix: upgrade to 1.2.2-1
Debian:14 debian phpldapadmin < 1.2.2-1
Fix: upgrade to 1.2.2-1
– phpldapadmin_project phpldapadmin <= 1.2.2
cpe:2.3:a:phpldapadmin_project:phpldapadmin:*:*:*:*:*:*:*:*
Original advisory text
Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_en...
Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.
Severity
4.3 Medium
Exploitation
5% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published11 Feb 2012
Updated31 Oct 2026
First seen5 Sep 2026
Sources
CVE-2012-0834 · NVD
Track software like this
Free during beta