Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.5

CVE-2012-0797: Moodle: Authenticated Users Can Access Deleted Services

CVE-2012-0797 · published 14 years ago
Summary

Authenticated Moodle users can access deleted services, potentially allowing them to view or modify sensitive data. This affects Moodle versions 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1. To fix the issue, update your Moodle installation to the latest version or apply a patch to prevent unauthorized access.

What to do
  • Update moodle moodle to version 2.2.1.
  • Update moodle moodle to version 2.1.4.
  • Update moodle moodle to version 2.0.7.
Affected software
Ecosystem VendorProductAffected versions
composer moodle moodle >= 2.2, < 2.2.1
>= 2.1, < 2.1.4
>= 2.0, < 2.0.7
Fix: upgrade to 2.2.1
– moodle moodle >= 2.0, <= 2.0.6
>= 2.1, <= 2.1.3
2.2.0
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*
Original advisory text
The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via...
The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.
Severity
5.5 Medium
Exploitation
1% chance of attack within 30 days
Type
CWE-287Improper Authentication
CWE-16Configuration
Timeline
Published17 Jul 2012
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2012-0797 · NVD
Track software like this
Free during beta