Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.8

CVE-2011-4947: e107 admin page lets attackers hijack admin login

CVE-2011-4947 · published 14 years ago
Summary

The e107 website software before version 0.7.26 has a flaw in its admin user management page. An attacker could trick an administrator into making a request that steals their login session and injects malicious code. Update e107 to version 0.7.26 or later, or apply the vendor's patch, to close the risk.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
e107 e107 <= 0.7.24
0.7
0.7.0
0.7.1
0.7.2
0.7.3
0.7.4
0.7.5
0.7.6
0.7.7
0.7.8
0.7.9
13 more version ranges
cpe:2.3:a:e107:e107:*:*:*:*:*:*:*:*
Original advisory text
Cross-site request forgery (CSRF) vulnerability in e107_admin/users_extended.php in e107 before 0.7.26 allows remote attackers to hijack the authentication of administrators for requests that inser...
Cross-site request forgery (CSRF) vulnerability in e107_admin/users_extended.php in e107 before 0.7.26 allows remote attackers to hijack the authentication of administrators for requests that insert cross-site scripting (XSS) sequences via the user_include parameter.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.8 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-352Cross-Site Request Forgery (CSRF)
Timeline
Published31 Aug 2012
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2011-4947 · NVD
Track software like this
Free during beta