Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2011-4909: Joomla! 1.5 allows attackers to run malicious scripts

CVE-2011-4909 · published 14 years ago
Summary

Versions of Joomla! prior to 1.5.12 let a remote user place harmful code into pages by sending a crafted web address reference. This can cause the site to display unwanted content or steal visitor information. Updating Joomla! to version 1.5.12 or later removes the risk.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
joomla joomla\! <= 1.5.11
1.5.0
1.5.1
1.5.2
1.5.3
1.5.4
1.5.5
1.5.6
1.5.7
1.5.8
1.5.9
1.5.10
cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*
Original advisory text
Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.5.12 allow remote attackers to inject arbitrary web script or HTML via the HTTP_REFERER header to (1) components/com_content/...
Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.5.12 allow remote attackers to inject arbitrary web script or HTML via the HTTP_REFERER header to (1) components/com_content/views/article/tmpl/form.php, (2) components/com_user/controller.php, (3) plugins/system/legacy/html.php, or (4) templates/beez/html/com_content/article/form.php.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published7 Oct 2012
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2011-4909 · NVD
Track software like this
Free during beta