Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2011-4107: phpMyAdmin allows attackers to read sensitive files
CVE-2011-4107 · published 14 years ago
Summary
A security issue in phpMyAdmin allows attackers who are logged in to your system to read any file on the server. This is a problem because it could let an attacker see sensitive information that they shouldn't have access to. To fix this, update phpMyAdmin to the latest version or remove the XML import plug-in.
What to do
- Update phpmyadmin phpmyadmin to version 3.4.7.1.
- Update phpmyadmin phpmyadmin to version 3.3.10.5.
- Update debian phpmyadmin to version 4:3.4.7.1-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| composer | phpmyadmin | phpmyadmin |
>= 3.4.0, < 3.4.7.1 >= 3.3.0, < 3.3.10.5 Fix: upgrade to 3.4.7.1
|
| – | phpmyadmin | phpmyadmin |
>= 3.3.0.0, < 3.3.10.5 >= 3.4.0.0, < 3.4.7.1 cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* |
| – | fedoraproject | fedora |
14 15 16 cpe:2.3:o:fedoraproject:fedora:14:*:*:*:*:*:*:* |
| – | debian | debian_linux |
5.0 cpe:2.3:o:debian:debian_linux:5.0:*:*:*:*:*:*:* |
| Debian:11 | debian | phpmyadmin |
< 4:3.4.7.1-1 Fix: upgrade to 4:3.4.7.1-1
|
| Debian:12 | debian | phpmyadmin |
< 4:3.4.7.1-1 Fix: upgrade to 4:3.4.7.1-1
|
| Debian:13 | debian | phpmyadmin |
< 4:3.4.7.1-1 Fix: upgrade to 4:3.4.7.1-1
|
| Debian:14 | debian | phpmyadmin |
< 4:3.4.7.1-1 Fix: upgrade to 4:3.4.7.1-1
|
Original advisory text
The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitr...
The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4107
- https://bugzilla.redhat.com/show_bug.cgi?id=751112
- https://exchange.xforce.ibmcloud.com/vulnerabilities/71108
- http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069625.h...
- http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069635.h...
- http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069649.h...
- http://packetstormsecurity.org/files/view/106511/phpmyadmin-fileread.txt
- http://seclists.org/fulldisclosure/2011/Nov/21
- http://securityreason.com/securityalert/8533
- http://www.debian.org/security/2012/dsa-2391
- http://www.openwall.com/lists/oss-security/2011/11/03/3
- http://www.openwall.com/lists/oss-security/2011/11/03/5
- http://www.phpmyadmin.net/home_page/security/PMASA-2011-17.php
- https://github.com/phpmyadmin/phpmyadmin/commit/2fbf631384fd8cded55f4500cb87b129...
- https://github.com/phpmyadmin/phpmyadmin/commit/34d99de000de9d15cfdf5e9cc8b7682d...
- https://github.com/phpmyadmin/phpmyadmin/commit/5fa86b8e81565c15ddbc359e8f59ecd8...
- https://github.com/phpmyadmin/phpmyadmin/commit/a5e206fbd2ca814042cfc1bb7dd3b40c...
- https://github.com/advisories/GHSA-q4mm-89q2-xffg
- http://osvdb.org/76798 Broken Link
- http://secunia.com/advisories/46447 Broken Link Vendor Advisory
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:198 Broken Link
- http://www.securityfocus.com/bid/50497 Broken Link Third Party Advisory VDB Entry
- http://www.wooyun.org/bugs/wooyun-2010-03185 Broken Link Exploit
- https://security-tracker.debian.org/tracker/CVE-2011-4107 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-200Information Exposure
CWE-611XML External Entity (XXE)
Timeline
Published17 Nov 2011
Updated22 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta