Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2011-3130: WordPress taxonomy queries can be manipulated to affect database
CVE-2011-3130 · published 15 years ago
Summary
Versions of WordPress included in Debian up to 3.1.2 and early 3.2 releases let specially crafted requests change how taxonomy data is handled, which could let an attacker alter or retrieve database information. Updating WordPress to the latest released version or applying the security patches provided by Debian eliminates this risk.
What to do
- Update debian wordpress to version 3.2.1+dfsg-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | wordpress |
< 3.2.1+dfsg-1 Fix: upgrade to 3.2.1+dfsg-1
|
| Debian:13 | debian | wordpress |
< 3.2.1+dfsg-1 Fix: upgrade to 3.2.1+dfsg-1
|
| Debian:14 | debian | wordpress |
< 3.2.1+dfsg-1 Fix: upgrade to 3.2.1+dfsg-1
|
| – | wordpress | wordpress |
3.1 3.1.1 3.1.2 3.2 cpe:2.3:a:wordpress:wordpress:3.1:*:*:*:*:*:*:* |
Original advisory text
wp-includes/taxonomy.php in WordPress 3.1 before 3.1.3 and 3.2 before Beta 2 has unknown impact and attack vectors related to "Taxonomy query hardening," possibly involving SQL injection.
wp-includes/taxonomy.php in WordPress 3.1 before 3.1.3 and 3.2 before Beta 2 has unknown impact and attack vectors related to "Taxonomy query hardening," possibly involving SQL injection.
References
- https://security-tracker.debian.org/tracker/CVE-2011-3130 Vendor Advisory
- http://secunia.com/advisories/49138
- http://wordpress.org/news/2011/05/wordpress-3-1-3/ Patch
- http://www.debian.org/security/2012/dsa-2470
- http://www.securityfocus.com/bid/47995
- https://exchange.xforce.ibmcloud.com/vulnerabilities/69169
Severity
7.5
High
Type
CWE-89SQL Injection
Timeline
Published10 Aug 2011
Updated3 Nov 2026
First seen11 Sep 2026
Track software like this
Free during beta