Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.8

CVE-2011-3052: Google Chrome before 17.0.963.83 can crash from web content

CVE-2011-3052 · published 14 years ago
Summary

Web pages that use certain graphics features can cause Google Chrome versions earlier than 17.0.963.83 to run out of memory and stop working. This may affect users on OpenSUSE systems that run these Chrome versions. Updating Chrome to a newer version fixes the issue.

What to do
  • Update google chrome to version 18.0.1025.142 or later.
Affected software
VendorProductAffected versions
google chrome < 18.0.1025.142
cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:*
opensuse opensuse 12.1
cpe:2.3:o:opensuse:opensuse:12.1:*:*:*:*:*:*:*
Original advisory text
The WebGL implementation in Google Chrome before 17.0.963.83 does not properly handle CANVAS elements, which allows remote attackers to cause a denial of service (memory corruption) or possibly hav...
The WebGL implementation in Google Chrome before 17.0.963.83 does not properly handle CANVAS elements, which allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.8 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-119Buffer Overflow
Timeline
Published22 Mar 2012
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2011-3052 · NVD
Track software like this
Free during beta