Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.8
CVE-2011-2697: HP Linux Imaging and Printing (HPLIP) allows remote code execution
CVE-2011-2697 · published 15 years ago
Summary
A vulnerability in HP Linux Imaging and Printing (HPLIP) allows an attacker to execute malicious code on a victim's computer by sending a specially crafted print file. This could lead to unauthorized access or data theft. HP Linux Imaging and Printing users should update to the latest version to fix this issue.
What to do
- Update debian foomatic-filters to version 4.0.
- Update debian hplip to version 3.10.6-2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:11 | debian | foomatic-filters |
< 4.0 Fix: upgrade to 4.0
|
| Debian:12 | debian | foomatic-filters |
< 4.0 Fix: upgrade to 4.0
|
| Debian:13 | debian | foomatic-filters |
< 4.0 Fix: upgrade to 4.0
|
| Debian:14 | debian | foomatic-filters |
< 4.0 Fix: upgrade to 4.0
|
| Debian:11 | debian | hplip |
< 3.10.6-2 Fix: upgrade to 3.10.6-2
|
| Debian:12 | debian | hplip |
< 3.10.6-2 Fix: upgrade to 3.10.6-2
|
| Debian:13 | debian | hplip |
< 3.10.6-2 Fix: upgrade to 3.10.6-2
|
| Debian:14 | debian | hplip |
< 3.10.6-2 Fix: upgrade to 3.10.6-2
|
| – | hp | linux_imaging_and_printing_project |
3.11.5 cpe:2.3:a:hp:linux_imaging_and_printing_project:3.11.5:*:*:*:*:*:*:* |
Original advisory text
foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.
foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.
References
- https://security-tracker.debian.org/tracker/CVE-2011-2697 Vendor Advisory
- http://security.gentoo.org/glsa/glsa-201203-07.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:125
- http://www.openwall.com/lists/oss-security/2011/07/13/3 Exploit Patch
- http://www.openwall.com/lists/oss-security/2011/07/18/3 Exploit Patch
- http://www.openwall.com/lists/oss-security/2011/07/28/1 Exploit Patch
- http://www.ubuntu.com/usn/USN-1194-1
- http://www.xerox.com/download/security/security-bulletin/16287-4d6b7b0c81f7b/cer...
- https://bugzilla.novell.com/show_bug.cgi?id=698451 Exploit Patch
- https://bugzilla.redhat.com/show_bug.cgi?id=721001 Exploit Patch
- https://exchange.xforce.ibmcloud.com/vulnerabilities/68993
Severity
6.8
Medium
Type
CWE-20Improper Input Validation
Timeline
Published29 Jul 2011
Updated24 Oct 2026
First seen8 Jun 2026
Track software like this
Free during beta