Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2011-2672: SemanticScuttle could let attackers run malicious scripts

CVE-2011-2672 · published 15 years ago
Summary

The SemanticScuttle web tool lets a remote attacker embed harmful code into pages that users view. This can lead to stolen data or altered page content. Update to version 0.98 or later, or apply the vendor’s patch, and make sure user input is properly filtered.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
christian_weiske semanticscuttle <= 0.97
0.85
0.86
0.87
0.88
0.89
0.90
0.91
0.92
0.93
0.94
0.95
1 more version range
cpe:2.3:a:christian_weiske:semanticscuttle:*:*:*:*:*:*:*:*
Original advisory text
Cross-site scripting (XSS) vulnerability in SemanticScuttle before 0.98 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Cross-site scripting (XSS) vulnerability in SemanticScuttle before 0.98 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published20 Sep 2011
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2011-2672 · NVD
Track software like this
Free during beta