Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2011-1958: Wireshark may crash when opening malicious file

CVE-2011-1958 · published 15 years ago
Summary

The Wireshark program packaged for Debian can be forced to stop working if a user opens a specially crafted Diameter dictionary file. This causes the application to crash, interrupting any network analysis tasks. Upgrade to Wireshark version 1.2.17 or later (or 1.4.7 or later) to prevent the issue.

What to do
  • Update debian wireshark to version 1.6.0-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian wireshark < 1.6.0-1
Fix: upgrade to 1.6.0-1
Debian:13 debian wireshark < 1.6.0-1
Fix: upgrade to 1.6.0-1
Debian:14 debian wireshark < 1.6.0-1
Fix: upgrade to 1.6.0-1
– wireshark wireshark 1.2
1.2.0
1.2.1
1.2.2
1.2.3
1.2.4
1.2.5
1.2.6
1.2.7
1.2.8
1.2.9
1.2.10
13 more version ranges
cpe:2.3:a:wireshark:wireshark:1.2:*:*:*:*:*:*:*
Original advisory text
Wireshark 1.2.x before 1.2.17 and 1.4.x before 1.4.7 allows user-assisted remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted Diameter dicti...
Wireshark 1.2.x before 1.2.17 and 1.4.x before 1.4.7 allows user-assisted remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted Diameter dictionary file.
Severity
4.3 Medium
Exploitation
3% chance of attack within 30 days
Timeline
Published6 Jun 2011
Updated30 Oct 2026
First seen11 Sep 2026
Sources
CVE-2011-1958 · NVD
Track software like this
Free during beta