Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2011-0430: OpenAFS Rx server can be crashed or hijacked remotely

CVE-2011-0430 · published 15 years ago
Summary

The Rx server component in OpenAFS versions 1.4.7, 1.4.12, and 1.4.14 may free the same memory twice, which can cause the service to stop working or allow an attacker to run their own code. This could disrupt file sharing services and expose your system to unauthorized control. Apply the latest OpenAFS updates or patches provided by your Linux distribution to fix the issue.

What to do
  • Update debian openafs to version 1.4.14+dfsg-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian openafs < 1.4.14+dfsg-1
Fix: upgrade to 1.4.14+dfsg-1
Debian:13 debian openafs < 1.4.14+dfsg-1
Fix: upgrade to 1.4.14+dfsg-1
– openafs openafs 1.4.7
1.4.12
1.4.14
cpe:2.3:a:openafs:openafs:1.4.7:*:*:*:*:*:*:*
Original advisory text
Double free vulnerability in the Rx server process in OpenAFS 1.4.14, 1.4.12, 1.4.7, and possibly other versions allows remote attackers to cause a denial of service and execute arbitrary code via ...
Double free vulnerability in the Rx server process in OpenAFS 1.4.14, 1.4.12, 1.4.7, and possibly other versions allows remote attackers to cause a denial of service and execute arbitrary code via unknown vectors.
Severity
7.5 High
Exploitation
3% chance of attack within 30 days
Type
CWE-399Resource Management Errors
Timeline
Published19 Feb 2011
Updated30 Oct 2026
First seen11 Sep 2026
Sources
CVE-2011-0430 · NVD
Track software like this
Free during beta