Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
10.0

CVE-2010-3119: Google Chrome and WebKitGTK allow crash via crafted Ruby

CVE-2010-3119 · published 16 years ago
Summary

Versions of Google Chrome prior to 5.0.375.127 and WebKitGTK prior to 1.2.6 mishandle Ruby content, which can cause the program to stop working. This could let a malicious web page make the browser or application freeze or shut down. Upgrade to the latest releases of Chrome and WebKitGTK to stop the issue.

What to do
  • Update google chrome to version 5.0.375.127 or later.
  • Update webkitgtk webkitgtk to version 1.2.6 or later.
Affected software
VendorProductAffected versions
google chrome < 5.0.375.127
cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:*
webkitgtk webkitgtk < 1.2.6
cpe:2.3:a:webkitgtk:webkitgtk:*:*:*:*:*:*:*:*
Original advisory text
Google Chrome before 5.0.375.127 and webkitgtk before 1.2.6 do not properly support the Ruby language, which allows attackers to cause a denial of service (memory corruption) or possibly have unspe...
Google Chrome before 5.0.375.127 and webkitgtk before 1.2.6 do not properly support the Ruby language, which allows attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
10.0 Critical
Exploitation
1% chance of attack within 30 days
Type
CWE-119Buffer Overflow
Timeline
Published24 Aug 2010
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2010-3119 · NVD
Track software like this
Free during beta