Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2009-5158: Google Analyticator plugin allows unsafe HTML injection
CVE-2009-5158 · published 7 years ago
Summary
The Google Analyticator add‑on for WordPress does not properly clean up HTML that it receives from the Google Analytics service. This could let an attacker inject malicious code into your site, potentially compromising visitor data or site functionality. Update the plugin to version 5.2.1 or later to fix the issue.
What to do
- Update sumo google_analyticator to version 5.2.1 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| sumo | google_analyticator |
< 5.2.1 cpe:2.3:a:sumo:google_analyticator:*:*:*:*:*:wordpress:*:* |
Original advisory text
The google-analyticator plugin before 5.2.1 for WordPress has insufficient HTML sanitization for Google Analytics API text.
The google-analyticator plugin before 5.2.1 for WordPress has insufficient HTML sanitization for Google Analytics API text.
References
- https://wordpress.org/plugins/google-analyticator/#developers Release Notes Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-20Improper Input Validation
Timeline
Published22 Aug 2019
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2009-5158 · NVD
Track software like this
Free during beta