Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.3

CVE-2009-4376: Wireshark may crash or be hijacked by crafted packet

CVE-2009-4376 · published 16 years ago
Summary

Wireshark versions 1.2.0 through 1.2.4 can be sent specially crafted network data that overflows a memory buffer. This can cause the program to stop working or, in some cases, allow an attacker to run their own code. Update to a newer version of Wireshark to protect your systems.

What to do
  • Update debian wireshark to version 1.2.5-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian wireshark < 1.2.5-1
Fix: upgrade to 1.2.5-1
Debian:13 debian wireshark < 1.2.5-1
Fix: upgrade to 1.2.5-1
Debian:14 debian wireshark < 1.2.5-1
Fix: upgrade to 1.2.5-1
– wireshark wireshark 1.2.0
1.2.1
1.2.2
1.2.3
1.2.4
cpe:2.3:a:wireshark:wireshark:1.2.0:*:*:*:*:*:*:*
Original advisory text
Buffer overflow in the daintree_sna_read function in the Daintree SNA file parser in Wireshark 1.2.0 through 1.2.4 allows remote attackers to cause a denial of service (crash) and possibly execute ...
Buffer overflow in the daintree_sna_read function in the Daintree SNA file parser in Wireshark 1.2.0 through 1.2.4 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted packet.
Severity
9.3 Critical
Exploitation
7% chance of attack within 30 days
Type
CWE-119Buffer Overflow
Timeline
Published21 Dec 2009
Updated4 Nov 2026
First seen17 Sep 2026
Sources
CVE-2009-4376 · NVD
Track software like this
Free during beta