Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.3
CVE-2009-4039: Piwigo before 2.0.6 can run malicious scripts
CVE-2009-4039 · published 16 years ago
Summary
The Piwigo photo gallery software versions earlier than 2.0.6 let attackers insert their own web code into pages. This could let a malicious person display unwanted content or steal information from visitors. Update Piwigo to version 2.0.6 or later, or apply the provided security patch.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| piwigo | piwigo |
<= 2.0.5 2.0.0 2.0.1 2.0.2 2.0.3 2.0.4 cpe:2.3:a:piwigo:piwigo:*:*:*:*:*:*:*:* |
Original advisory text
Cross-site scripting (XSS) vulnerability in Piwigo before 2.0.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Cross-site scripting (XSS) vulnerability in Piwigo before 2.0.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
References
- http://piwigo.org/releases/2.0.6 Patch Vendor Advisory
- http://secunia.com/advisories/37336 Vendor Advisory
- http://www.vupen.com/english/advisories/2009/3221 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Severity
4.3
Medium
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published20 Nov 2009
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2009-4039 · NVD
Track software like this
Free during beta