Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.3
CVE-2009-2186: Adobe Shockwave Player before 11.0.0.465 can be hijacked
CVE-2009-2186 · published 17 years ago
Summary
Versions of Adobe Shockwave Player older than 11.0.0.465 can be tricked into running the attacker’s code. This could let a remote hacker take control of a computer, steal information, or install unwanted software. Install the latest Shockwave Player update (11.0.0.465 or newer) or remove the player if it’s not needed.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| adobe | shockwave_player |
<= 11.0.0.456 1.0 2.0 3.0 4.0 5.0 6.0 8.0 8.5.1 9 10.1.0.11 cpe:2.3:a:adobe:shockwave_player:*:*:*:*:*:*:*:* |
Original advisory text
Unspecified vulnerability in Adobe Shockwave Player before 11.0.0.465 allows remote attackers to execute arbitrary code via unknown vectors, a different vulnerability than CVE-2009-1860, related to...
Unspecified vulnerability in Adobe Shockwave Player before 11.0.0.465 allows remote attackers to execute arbitrary code via unknown vectors, a different vulnerability than CVE-2009-1860, related to an older issue that "was previously resolved in Shockwave Player 11.0.0.465."
References
- http://www.adobe.com/support/security/bulletins/apsb09-08.html Patch Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Severity
9.3
Critical
Timeline
Published25 Jun 2009
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2009-2186 · NVD
Track software like this
Free during beta